はてなブログ開発ブログ

はてなブログの新機能など開発に関する情報、公式のお知らせを発信します。

Android 7.1以前の古いOSでのご利用に関するお知らせと、Androidアプリのサポート対象バージョン変更のお知らせ

いつもはてなブログをご利用いただきありがとうございます。

はてなブログで利用しているSSL/TLS証明書の認証局*1の変更が 2020年9月30日に行われる予定です。その結果、Android 7.1以前などの古いOSをお使いの場合に、HTTPS配信を利用しているはてなブログやダッシュボードなどの管理ページなど複数のページで、順次「この接続ではプライバシーは保護されません」と警告が表示されるようになります。ご利用のユーザー様には、ご不便をおかけいたしますが、何卒ご了承ください。

なお、Android 7.1 以前のバージョンをご利用の場合でも、Firefoxブラウザよりご利用いただく場合には、上記の警告が表示されない場合もあるとの報告もございます。もし、ご利用上の問題がある場合には、Firefoxブラウザからのご利用をご検討ください。

AndroidアプリのサポートOSバージョンについて

上記のような事情を鑑み、Androidアプリについても、古いバージョンのAndroidにて、十分なサポートを行うことが困難と考え、2020年9月30日以降のリリースにおいては、AndroidアプリのサポートをAndroid 8.0以上に変更いたします。ご了承ください。

*1:Let’s Encrypt